bitmex-test

test incident
Resolved·Degraded performance

test incident resolved

Mon, Mar 2, 2026, 03:16 AM
(1 day ago)
·
Affected components
Updates

Resolved

test incident resolved

Mon, Mar 2, 2026, 03:16 AM

Investigating

test updated

Mon, Mar 2, 2026, 03:13 AM

Investigating

test incident

Mon, Mar 2, 2026, 02:59 AM(14 minutes earlier)
Powered by

This is a test - if you've found this please check our live status page instead https://status.bitmex.com